Downgrade iOS 5.1 to iOS 4.3.5 and Below | How to

An hour ago I wrote a guide on how to downgrade iOS 5.1 to iOS 5.0.1 and 5.0 on iPad, iPhone 4, 3GS and iPod Touch using iFaith. (The full guide you can find here). But this method is not working on iPad 2, because you can downgrade iOS 5.1 on iPad 2 to iOS 4.3.5 and below. So I decided to write you a guide on how to downgrade iOS 5.1 to iOS 4.3.5 and below.

READ MORE +

Save iPhone 4 SHSH Blobs Before Firmware Update

There was the news that TinyUmbrella had been updated. And now it can support iPhone 4 on iOS 4. But first you should save your SHSH Blobs files. Why? Because next week we will see a new firmware update. But if you have your SHSH blobs on file then you need downgrade baseband 04.11.08 on  iOS 4.0.1 to iOS 4. SHSH Blob is a signature file which is verified against Apple Server to verify the the iPhone is running the latest version of iOS.

READ MORE +